What is the best browser to use with Picaboo?

Picaboo works with Mozilla Firefox, Google Chrome, Safari, or Internet Explorer 9 or later.

Flash player 11 or above will be needed. To update to the latest version of Adobe Flash Player, click here. The minimum system requirements for Flash 11 can be found here.

Whichever browser you choose to use, you'll want to make sure that it's updated to the latest version. Directions for updating your browser can be found here:

< View our Minimum System Requirements

Have more questions? Submit a request

Comments

  • 61f9576b31f227988f4b8b27cab9dfef?default=https%3a%2f%2fassets.zendesk.com%2fimages%2fframe_user
    Pdxdaddyt

    Picaboo does not work well with the new updated Firefox in China. I live in China and teach at an international school. Picaboo is great but from here, it gets blocked by China's Great Firewall. I have to use a VPN and Google Chrome in order for it to work seamlessly, otherwise it will show the website as unavailable. Even with a VPN, Firefox will allow you to log in and it will show you your bookshelf, but there are no books on it to edit. Not sure how many people this affects, but thought it could be helpful information.

Please sign in to leave a comment.